You are running PHP 5.6.37-1+ubuntu14.04.1+deb.sury.org+1, but Grav needs at least PHP 7.1.3 to run.